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Introduction

Thank you for purchasing a Panasonic product. Before you use the product, please carefully
read through the installation instructions and the manuals, and understand them in detail to use
the product properly.

Types of Manual

● There are different types of manuals for the GM1 series. Refer to the appropriate manual
according to your need.
These manuals can be downloaded from our website: https://industrial.panasonic.com/ac/e/
motor/motion-controller/mc/gm1/index.jsp.

Manuals for GM1 series

Manual name Manual code Description

GM1 Controller RTEX User's Manual
(Setup)

WUME-
GM1RTXSU

Explains wiring between the GM1 and its
peripheral devices, installation method, and
operation check method.

GM1 Controller RTEX User's Manual
(Operation)

WUME-
GM1RTXOP

Explains how to use GM Programmer and
PANATERM Lite for GM, set up each function,
create projects, and perform other operations.

GM1 Series Reference Manual
(Hardware)

WUME-GM1H Explains the functions and performance of each
GM1 unit.

GM1 Series Reference Manual
(Instruction)

WUME-GM1PGR Explains the specifications of each instruction that
can be used with the GM1 Series.

GM1 Series Reference Manual
(Analog I/O Unit)

WUME-GM1AIO Explains the functions and performance of the
Analog Expansion Unit.

GM1 Series Reference Manual
(Pulse Output Unit)

WUME-GM1PG Explains the functions and performance of the
GM1 Pulse Output Unit.

Copyright / Trademarks

● The copyright of this manual is owned by Panasonic Industry Co., Ltd..
● Unauthorized reproduction of this manual is strictly prohibited.
● Windows is a registered trademark of Microsoft Corporation in the U.S. and other countries.
● Ethernet is a registered trademark of FUJIFILM Business Innovation Corp. and Xerox Corporation.
● EtherNet/IP is a registered trademark of ODVA (Open DeviceNet Vendor Association).
● SDHC and SD logos are trademarks of LLC.
● Other company and product names are trademarks or registered trademarks of their respective companies.
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1.1 Safety Precautions

This section explains important rules that must be observed to prevent personal injury and
property damage.
● Injuries and damages that may occur as a result of incorrect use are classified into the

following levels and safety precautions are explained according to the level.

Indicates that there is a risk of death or serious injury

Indicates that there is a risk of minor injury or property damage

Indicates an action that is prohibited

Indicates an action that must be taken

● Take safety measures outside this product to ensure the safety of the entire system even
if this product fails or an error occurs due to external factors.

● Do not use this product in atmospheres that contain flammable gases.
Doing so may result in explosion.

● Do not throw this product into the fire.
Doing so may cause the batteries or other electronic parts to explode.

● To prevent abnormal heat generation or smoke generation, use this product with some
leeway from the guaranteed characteristics and performance values of the product.

● Do not disassemble or modify this product.
Doing so may result in abnormal heat generation or smoke generation.

● Do not touch any terminals while the power is on.
Doing so may result in electrical shock.

● Configure emergency stop and interlock circuits outside this product.

● Connect wires and connectors properly.
Failure to do so may result in abnormal heat generation or smoke generation.

● Do not perform work (such as connection or removal) with the power turned on.
Doing so may result in electrical shock.

● If this product is used in any way that is not specified by Panasonic, its protection function
may be impaired.

● This product has been developed and manufactured for industrial use only.

1.1 Safety Precautions
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1.2 Description of Icons Used in this Document

■ In this manual, the following symbols are used to indicate safety information that
must be observed.

Indicates an action that is prohibited or a matter that requires caution.

Indicates an action that must be taken.

Indicates supplemental information.

Indicates details about the subject in question or information useful to remember.

Indicates operation procedures.

1.2 Description of Icons Used in this Document
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1.3 Software License Agreement

Panasonic Industry Co., Ltd. (“PANASONIC”) grants to you a license to use this Software on
condition that you accept this Agreement. You must read this Software License Agreement (this
“Agreement”) carefully before using this Software. Only in case that you accept this Agreement,
you may start your use of this Software.
Your unsealing the package of this Software, or your downloading, installing or launching this
Software or the like shall be deemed as your acceptance of this Agreement.
The Software includes not only proprietary computer programs owned by or licensed by
PANASONIC but also open source software programs. As for the open source software
programs, refer to the detailed terms and conditions thereof shown in the installation package of
the Software. Should a discrepancy arise between any of the terms of this Agreement and any
open source software program license statement, the open source software program license
statement shall take precedence over this Agreement.
Article 1 Grant of License
PANASONIC hereby grants to you a non-exclusive license to use this Software only in
combination with PANASONIC product(s) specified in the manual of this Software (the
“Product”) in accordance with the terms of this Agreement. You may not use this Software in
connection with products of any third party other than PANASONIC.
Article 2 Restrictions
You may NOT:
1. Modify, reverse engineer, decompile, or disassemble this Software, except where the terms

and conditions of open source software program license statement (including, but not
limited to, GPL and LGPL) apply.
Should a defect of the Software arise owing to your modification, reverse engineering,
decompiling, or disassembling, to the extent permitted under the law,PANASONIC shall not
assume any responsibility for such defect,

2. Use this Software by methods or for purposes other than those specified in the manual of
this Software provided by PANASONIC, nor

3. Distribute, rent, lease or otherwise transfer this Software to any third party; provided,
however, that you may assign the rights to use this Software under this Agreement along with
the Product on the condition that the assignee agrees to be bound by all the terms of this
Agreement. In the case of such assignment, you must deliver any and all the copies of this
Software and all the accompanying materials to the assignee and you may not retain any
copies of this Software including backups.
Article 3 Disclaimer
1. PANASONIC HEREBY DISCLAIMS ALL OTHER WARRANTIES ON THIS SOFTWARE,

EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED
WARRANTIES OF MARCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE, AND
NON-INFRINGEMENT OF THIRD PARTY RIGHTS.

2. UNDER NO CIRCUMSTANCES SHALL PANASONIC BE LIABLE FOR ANY DAMAGES
(INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL OR SPECIAL OR
WHATSOEVER) ARISING OUT OF THE USE OF THIS SOFTWARE, INABILITY TO USE
THIS SOFTWARE, DEFECTS IN THIS SOFTWARE (e.g., BUGS, SECURITY HOLES,
AND MALFUNCTION), OR OTHERWISE IN CONNECTION WITH THIS SOFTWARE.

Article 4 Term
1. This Agreement shall come into effect upon your unsealing the package of this Software, or

your downloading, installing or launching this Software or the like.

1.3 Software License Agreement
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2. PANASONIC may terminate this Agreement immediately, if you breach any of the
provisions of this Agreement.

3. You shall, at your own costs, return, delete or destroy this Software and any of its copies
within four (4) weeks after termination of this Agreement.

Article 5 Export Control
You shall comply with all laws and regulations regarding export control under any competent
jurisdiction, including but not limited to the Japanese Foreign Exchange & Foreign Trade
Control Law, the export control regulations based on resolutions of the United Nations Security
Council, etc. If any license or appropriate approval from a governmental authority is required
under the applicable laws, you may not export this Software without such approval to any
countries either directly or indirectly. Furthermore, you shall neither use nor sell this Software
for military purposes either directly or indirectly.
Article 6 Intellectual Property Rights
Except the open source software program (including, but not limited to, GPL and LGPL), all
intellectual property rights in this Software, including the copyright, belong to PANASONIC
and/or the licensors of PANASONIC.
Article 7 Upgrade of this Software
1. Release of future upgrades or updates of this Software is not guaranteed and left to the

sole discretion of PANASONIC. Furthermore, PANASONIC may charge fees for upgrading
or updating of this Software.

2. If any upgrades or updates are provided to you either for fees or for free, such upgrades or
updates shall be deemed as a part of this Software and shall be governed by this
Agreement, unless PANASONIC designates otherwise at the time of provision of such
upgrades or updates.

Article 8 Limitation on Liability
AGGREGATE LIABILITIES OF PANASONIC IN CONNECTION WITH THIS AGREEMENT OR
THIS SOFTWARE SHALL IN NO EVENT EXCEED TEN THOUSAND (10,000) YEN.
Article 9 Governing Law and Jurisdiction
1. This Agreement shall be governed by the laws of Japan.
2. Should any dispute arise from or in connection with this Agreement, Osaka District Court,

Japan shall exclusively have the jurisdiction over such dispute.
This Software consists of the following types of software.
1. Software developed independently by PANASONIC
2. Software owned by and licensed by the third party
3. Software licensed under GNU General Public License Version 2.0 (GPL V2.0)
4. Software licensed under GNU Lesser General Public License Version 2.0 (LGPL V2.0) or

Version 2.1 (LGPL V2.1)
5. Open source software licensed on conditions other than those of GPL V2.0, LGPL V2.0, or

LGPL V2.1
Software in categories 3. - 5. above is distributed with the expectation of effectiveness as a
single piece of software, but there is no guarantee provided, including implied guarantees
regarding viability as a product and/or suitability for specific purposes. For details, Please refer
to the detailed terms and conditions thereof shown in the installation package of the Software.
For at least three years following the release of the Product, PID will provide, at customer's
expense, complete machine-readable source code for software licensed under GPL V2.0,
LGPL V2.0, LGPL V2.1, or a license based on other conditions that meet source code
disclosure requirements, along with information on the respective copyright holders, to
customers who contact us at the following e-mail address.
【Contact e-mail address: oss-cd-request@gg.jp.panasonic.com】

1.3 Software License Agreement

WUME-GM1RTXSU-05 1-5



(MEMO)

1-6 WUME-GM1RTXSU-05



2 Basic System Configuration

2.1  Outline of the GM1 System.................................................................2-2
2.2  Unit Types...........................................................................................2-3
2.3  Restrictions on the Number of Expansion Units .................................2-5
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2.1 Outline of the GM1 System

■ Network control
A MINAS series servomotor network system can be easily configured using the RTEX network
dedicated to motion control.

■ System configuration including virtual axes
A motion system that combines real and virtual axes can be configured.

■ Two LAN ports
Other than the RTEX, there are two Ethernet connection ports.
Each port can have a unique IP address. They can be used for different purposes, such as for
an in-device network or for a host system network.

■ Equipped with the high-speed counter input and PWM output
The GM1 Controller is equipped with a 2-ch high-speed counter input for 16 MHz (multiplied by
4) and a 4-ch PWM output that can output a maximum of 100 kHz. These functions can be
used without adding expansion units.

2.1 Outline of the GM1 System
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2.2 Unit Types

■ Controller

Type Function Model number

RTEX-compatible GM1 Controller
(sink type)

RTEX motion controller
Transistor NPN output type

AGM1CSRX16T

■ Expansion units

Type Function Model number

Digital input (64 points) 24 V DC, 64 input points AGM1X64D2

Digital output (64 points) (sink type) Output (64 points)
Transistor NPN type AGM1Y64T

Digital output (64 points) (source
type)

Output (64 points)
Transistor PNP type AGM1Y64P

Digital I/O (64 points) (sink type)
24 V DC, 32 input points
32 output points
Transistor NPN type

AGM1XY64D2T

Digital I/O (64 points) (source type)
24 V DC, 32 input points
32 output points
Transistor PNP type

AGM1XY64D2P

Analog input (8 points) 8 input points AGM1AD8

Analog output (4 points) 4 output points AGM1DA4

Pulse output (transistor output type)
4-axis, pulse train, 500 kpps
Open collector output

AGM1PG04T

Pulse output (line driver output
type)

4-axis, pulse train, 4 Mpps
Line driver output

AGM1PG04L

2.2 Unit Types
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● For the RTEX-compatible GM1 Controller and expansion units to be used, compatible GM
Programmer versions are as follows.

Type Model number Version of GM Programmer

RTEX-compatible GM1 Controller (sink
type) AGM1CSRX16T Ver.1.0 or later

Digital input (64 points) AGM1X64D2 Ver.1.0 or later

Digital output (64 points) (sink type) AGM1Y64T Ver.1.0 or later

Digital output (64 points) (source type) AGM1Y64P Ver.1.2 or later

Digital I/O (64 points) (sink type) AGM1XY64D2T Ver.1.0 or later

Digital I/O (64 points) (source type) AGM1XY64D2P Ver.1.2 or later

Analog input (8 points) AGM1AD8 Ver.1.2 or later

Analog output (4 points) AGM1DA4 Ver.1.2 or later

Pulse output (transistor output type) AGM1PG04T Ver.1.2 or later

Pulse output (line driver output type) AGM1PG04L Ver.1.2 or later

2.2 Unit Types
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2.3 Restrictions on the Number of Expansion Units

Up to 15 expansion units can be mounted on the right side of the GM1 Controller.

(1) Controller (2) Expansion units (3) End unit

● Make sure to connect an end unit to the end of the system.

2.3 Restrictions on the Number of Expansion Units
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3 Restrictions on the GM1
Controller and Servo
Amplifiers

3.1  Restrictions on the Combination of the GM1 Controller and Servo
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3.2  Restrictions on Servo Amplifier Parameters .......................................3-3
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3.1 Restrictions on the Combination of the GM1 Controller and Servo
Amplifiers

As for the combination of the GM1 Controller and each MINAS series, confirm the following
restrictions.

Combination of the GM1 Controller and servo amplifiers

Connectable servo amplifier
Description

A5N A6N

● ● A5N and A6N can be connected to the same network.

● When using servo amplifiers in combination with the GM1 Controller, use the ones with the
latest software version.

■ Setting ranges of movement amount and speed
The input range of the movement amount or speed specified in the GM1 Controller may differ
from the upper and lower setting limits of the servo amplifier.

● The input range of the movement amount or speed specified in the GM1 Controller may differ
from the upper and lower setting limits of the servo amplifier.
• RTEX-compatible GM1 Controller: Communication cycle: 500 μs to 2 ms, Command update

cycle: 500 μs to 4ms
• Servo amplifier A5N: Communication cycle: 500 μs to 1 ms, Command update cycle: 500 μs

to 1 ms
• Servo amplifier A6N: Communication cycle: 500 μs to 2 ms, Command update cycle: 500 μs

to 4 ms

3.1 Restrictions on the Combination of the GM1 Controller and Servo
Amplifiers
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3.2 Restrictions on Servo Amplifier Parameters

Some parameters for servo amplifiers on the A5N/A6N side affect the behaviors of the RTEX-
compatible GM1 Controller. Use the following parameters.

No. Name Description
Standard
factory
default
setting

Pr5.04
Over-travel
inhibit input
setup

Use setting value “1 (Disable the over-travel inhibit input)”.
(Mandatory) 1(Note 1)

Pr7.22
RTEX function
extended setup
1

With a setting of 0 (16-byte mode), the maximum connection is 32
axes. With setting 1 (32-byte mode), the maximum number of
connections is 16 axes.
(Default setting value: 0)

0(Note 2)

Pr7.23
RTEX function
extended setup
2

Use setting value “18”.
(Mandatory)
This parameter sets each function in bits.

bit 0: Allow parameter values to be written via RTEX
communication

0: Allow, 1: Disallow

bit 1: Set a sub-number for alarm code
0: Fixed at 0, 1: Enable sub-number

bit 2: Set RTEX status response conditions when "Over-travel
inhibit input setup" is disabled (Pr5.04 = 1)

0: Enable status, 1: Fixed at 0

bit 3: Set RTEX status bit assignment for POT and NOT
0: POT corresponds to bit 1 and NOT corresponds to bit 0, 1: NOT
corresponds to bit 1 and POT corresponds to bit 0
0: POT corresponds to bit 1 and NOT corresponds to bit 0, 1: NOT
corresponds to bit 1 and POT corresponds to bit 0

bit 4: Set display mode for "COM" LED
0: Mode 1, 1: Mode 2

bit 5: Set non-cyclic command start mode
0: When a change from base command occurs
1: When command code or command argument changes

bit 6: Set RTEX status logic for POT and NOT
0: Do not reverse, 1: Reverse

bit 7: Set RTEX status logic for PSL and NSL
0: Do not reverse, 1: Reverse

bit 8: Select RTEX status from In_Progress / AC_OFF
0: In_Progress, 1: AC_OFF
(It is linked to the setting in bit 15.)

bit 9: Select whether to return a command error when a
command for motion toward the direction of over-travel
prohibition is received after deceleration stop is executed by
"Over-travel inhibit input setup"

0: Do not return a command error
1: Return a command error

18(Note 2)

3.2 Restrictions on Servo Amplifier Parameters
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No. Name Description
Standard
factory
default
setting

(Bit 10 to bit 13 are not used.)
Fix to "0".

bit 14: Set position deviation [command unit] output
0: Internal commanded position (after filtering) [command unit] -
Actual position [command unit]
1: Internal commanded position (before filtering) [command unit] -
Actual position [command unit]

Bit 15: Select extended RTEX status from In_Progress /
AC_OFF / Pr7.112 settings

0: Follow the setting of Pr7.23 bit 8 (In_Progress / AC_OFF)
1: Follow the setting of Pr7.112.

Pr7.25 RTEX speed
unit setup

Use setting value “1 (command unit/s)”.
(Mandatory) 0(Note 2)

 

(Note 1) We recommend that the set value should not be changed judging from the characteristics of the GM1
and MINAS.

(Note 2) Do not change the set value. If the set value is changed, the GM1 Controller will make an error stop.
 

3.2 Restrictions on Servo Amplifier Parameters
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4 Basic Operations of the GM1
Controller

4.1  Power ON ...........................................................................................4-2
4.2  Operation Mode Switching..................................................................4-3
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4.1 Power ON

When turning ON the power supply to the system incorporating the GM1 Controller, turn ON the
power supply in the following order.

● Consider the nature and statuses of any external devices connected to the system, and
take sufficient care so that turning ON the power supply will not initiate unexpected
movements.

1. Turn ON the power supplies to the I/O devices connected to the GM1 Controller.

2. Turn ON the power supply to the servo amplifier.

3. Turn ON the power supply to the GM1 Controller.

4.1 Power ON
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4.2 Operation Mode Switching

■ Switching to the RUN mode
There are the following two methods.
● Press the operation button (▶) on the GM Programmer while the STOP LED is lit.
● Set the RUN/STOP switch on the GM1 Controller to RUN.

● The switch cannot be set to the RUN mode if an error that does not allow to continue operation
has occurred or if an exceptional situation has occurred.

■ Switching to the STOP mode
There are the following two methods.
● Press the stop button (■) on the GM Programmer while the RUN LED is lit.
● Set the RUN/STOP switch on the GM1 Controller to STOP.

4.2 Operation Mode Switching
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5 Installation and System
Setup

5.1  System Configuration Diagram...........................................................5-2
5.2  Work Flowchart ...................................................................................5-4
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5.1 System Configuration Diagram

The figure below shows the configuration of the GM1 series motion controller (Controller and
expansion units), servo amplifiers, and PC. The GM Programmer and PANATERM Lite for GM
communicate with the GM1 Controller via Gateway.

No. Name

(1) GM1 controller

(2) Expansion unit

(3) End unit

(4) Servo amplifier

(5) PC (on which GM Programmer and PANATERM Lite for GM are installed)

(6) Gateway, CodeMeter

(7) GM Programmer

(8) PANATERM Lite for GM

(9) Ethernet cable(Note 1)

(10) USB cable(Note 1)

 

(Note 1) Use either one of the two cables: Ethernet cable or USB cable.
 

5.1 System Configuration Diagram

5-2 WUME-GM1RTXSU-05



● To operate the system, you must install GM Programmer and PANATERM Lite for GM on the
PC.

● When GM Programmer is installed, MINAS setup support software "PANATERM Lite for GM",
Gateway (the application that connects GM Programmer and the GM1 Controller), and
CodeMeter are installed at the same time.

5.1 System Configuration Diagram
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5.2 Work Flowchart

The following table explains the workflow from installation of the GM1 controller through to its
operation.

Step Description Reference

1 Install GM Programmer and PANATERM Lite for GM. "P.6-3"

2 Make preparations for the servo amplifiers. "P.8-1"

2-1 Connect the servo amplifiers and the PC. "P.8-2"

2-2 Install the USB driver on the PC. "P.8-2"

2-3 Configure initial settings for the servo amplifiers. "P.8-2"

2-4 Disconnect the servo amplifiers from the PC. "P.8-4"

3 Connect the GM1 Controller and each servo amplifier with cables. "P.9-1"

4 Connect the GM1 Controller and the GM Programmer. "P.10-1"

4-1 Connect the GM1 Controller and the PC with a cable. "P.10-2"

4-2 Creating a new project. "P.10-3"

4-3 Make communication settings. "P.10-6"

4-4 Add and set up device objects for servo amplifiers. "P.10-9"

4-5 Make basic settings of the RTEX axis "P.10-13"

4-6 Connect the GM1 Controller and each servo amplifier and perform
an operation check.

"P.10-19"

4-7 Log in to the GM1 Controller. "P.10-24"

4-8 Log out from the GM1 Controller. "P.10-25"

5 Connect the GM1 Controller and PANATERM Lite for GM. "P.11-1"

5-1 Set up the servo amplifier connected to the GM1 Controller. "P.11-2"

5-2 Write parameters to the servo amplifier. "P.11-6"

6 Prepare for operation. "P.12-1"

6-1 Check if safety circuit design is implemented. "P.12-3"

6-2 Check wiring for each device. "P.12-2"

6-3 Perform an operation check. "P.12-7"

7 Using the GM Programmer, make settings for GM1 parameters, motion
control, unit control, and communication function.

GM1 Controller
RTEX User's Manual
(Operation)

7-1 Make settings for the GM1 Controller.

7-2 Make settings for the motion control.

7-3 Make settings for the unit control.

7-4 Make settings for the communication function

8 Create programs with GM Programmer.

8-1 Create objects (POU objects) for a program.

8-2 Select a program language (LD program / ST program / SFC
program / FBD program / IL program / CFC program) and enter a
program.

5.2 Work Flowchart
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Step Description Reference

8-3 Set variables.

9 Set the GM1 controller with the GM Programmer.

9-1 Make time setting.

9-2 Log in to the GM1 Controller.

9-3 Log out from the GM1 Controller.

9-4 Upload the source.

10 Configure security settings with GM Programmer.

10-1 Configure user management settings.

10-2 Configure encryption and signature settings.

10-3 Configure write-protection settings.

5.2 Work Flowchart
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6.1 System Requirements

6.1.1 Usage Environment of the GM Programmer

Programming software

Product name Applicable language

GM Programmer Japanese / English / Chinese
 

(Note 1) When GM Programmer is installed, MINAS setup support software"PANATERM Lite for GM"is
installed at the same time.

 

Software operating environment

Item Description

OS
Microsoft(R) Windows(R) 10：32bit/64bit
Microsoft(R) Windows(R) 11：64bit

PC

PC with the following installed:
● Microsoft.NET Framework 4.6.1 or higher
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
● Microsoft Visual C++ 2013 Redistributable Package (x86)
● Microsoft Visual C++ 2013 Redistributable Package (x64)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x86)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x64)

HDD At least 4 GB of free space

Memory At least 8 GB

Communication port
LAN port (for Ethernet connection)
USB 2.0 port (for USB connection)

6.1 System Requirements
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6.2 Installation and Uninstallation

6.2.1 Installing GM Programmer

Before installing the GM Programmer on a PC, log on to the PC as an account with
Administrator privileges.
If other applications are running, be sure to close all the applications before installing GM
Programmer.

1. Double-click "setup.exe".
The following window will be displayed. Click [OK].

2. The following window will be displayed. Click [Install].
The display content differs according to the PC environment that you use. (This window
may not be displayed at all, depending on the situation.)

6.2 Installation and Uninstallation
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3. The following window will be displayed. Click [Next].

4. The following window will be displayed. Select [I accept the terms in the license agreement]
and click [Next].

5. The following window will be displayed. If you change the installation destination folder,
click [Change] and specify a desired installation destination. If you do not change the
installation destination folder, click [Next].

6.2 Installation and Uninstallation
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6. The window below will be displayed. Click [Install] to start the installation.

7. The following window will be displayed while the installation is in progress.

6.2 Installation and Uninstallation
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Following this installation, the three packages below will be installed. (The segments
indicated by * differ according to the version of the software.)
● CODESYS SoftMotion*.*.*.*_P
● GMPLibrary (*.*.*.*)
● PANATERM-Lite for GM V*.*
These packages take a long time to install. Take care not to click [Cancel] while the
installation is in progress.

8. When the installation of all the packages is completed, the following window will be
displayed. Click [Finish].

6.2 Installation and Uninstallation
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This completes the installation procedure.

● When the GM Programmer is installed, PANATERM Lite for GM, Gateway (CODESYS
Gateway), and CodeMeter applications are installed at the same time.

6.2.2 Uninstalling GM Programmer

1. From the Start menu, select Windows System>Control Panel, and then click "Uninstall a
program".
A list of installed programs will be displayed.

2. Double-click "Panasonic GM Programmer".
The following window will be displayed. [Yes]

3. Click the [Yes] button.
The GM Programmer will be uninstalled.

● When the GM Programmer is uninstalled, PANATERM Lite for GM and Gateway are also
uninstalled at the same time.

● CodeMeter will not be uninstalled at this time. Uninstall it separately.

6.2 Installation and Uninstallation
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6.3 Basic Operations

This section explains how to start and quit GM Programmer.

6.3.1 How to start

1. Click the [Start] button and select Panasonic Corpration>GM Programmer.
The "User Account Control" dialog box will be displayed. Click [Yes].

GM Programmer will be started.

6.3 Basic Operations
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6.3.2 How to quit

● Before closing GM Programmer, be sure to save any project files that you are editing and
must save.

1. From the menu bar, select File>Exit.
If changes have not been saved, the following window will be displayed.
If exiting without saving, select [No].
If changes need to be saved, select [Yes] to perform the save process.

2. Click the [Yes] button.
GM Programmer will be closed.

● You can also close GM Programmer by clicking the [×] button on the title bar.

6.3 Basic Operations
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6.4 Component Names

This section presents the name and display content of each component of GM Programmer.

No. Name Description

(1) Title bar The title bar displays the project file name, [minimize] button, [maximize] button, and
[close] button.

(2) Menu bar The menu bar displays the menu commands for each purpose in list format.

(3) Toolbar The toolbar displays each command as an icon.

(4) Navigator pane The navigator pane displays the objects (such as devices, applications, and programs)
added to the project in a tree structure.

(5) Main pane
The main pane displays a program, function settings, messages, and other data.
The window can be switched by selecting a desired tab.

(6) Status field The status bar displays the build status, logged-in users, and other information.

6.4 Component Names
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6.5 Other Functions

6.5.1 Display Language Setting Function

This function allows the user to change the display language setting for GM Programmer.
The default setting is the same language as the one used in the operating system. If you want
to use a different language from the one used in the operating system, change the display
language setting. After you change the language setting, you must restart GM Programmer.

1. From the menu bar, select Tools>Options.
The "Options" dialog box will be displayed.

2. Select "International Settings" from the Categories pane.
The "International Settings" pane will be displayed.

3. Select User Interface Language>Specific language option and specify a desired
language in the field.

4. Click [OK].
The "Options" dialog box will be closed.
At this stage, the language has not been changed yet.

5. Close GM Programmer and then start GM Programmer again.
After GM Programmer is started, the selected language takes effect.

6.5 Other Functions
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● The display language setting of GM Programmer is linked with that of PANATERM Lite for GM.
Therefore, if the display language setting of PANATERM Lite for GM is changed, the display
language setting of GM Programmer will also be changed automatically.

6.5.2 Online Help Function

This function allows the user to open the manual and check information such as operating
methods.

1. Press the [F1] key.
Online help will be started and the page corresponding to the displayed window will be
displayed.

6.5 Other Functions
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● You can also start online help by selecting Help>Manual from the menu bar.

6.5.3 Version Display Function

This function allows the user to check the version, license, and other information for GM
Programmer.

1. From the menu bar, select Help>Version Info.
The GM Programmer version is displayed in parentheses on the title bar.

2. Click a desired button at the bottom of the window.

Button Description

Version Info Displays information about the plug-ins that have been applied and the operating
system of the PC that is used.

License Info Displays license information for the software used by GM Programmer.

Clicking the[Version Info]button displays the"Version Info"dialog box.

6.5 Other Functions
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Clicking the[License Info]button displays the"License Information"dialog box.

6.5 Other Functions
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7.1 System Requirements

7.1.1 Operating Environment of PANATERM Lite for GM

Programming software

Product name Applicable language

PANATERM Lite for GM Japanese / English / Chinese
 

(Note 1) When GM Programmer is installed, MINAS setup support software"PANATERM Lite for GM"is
installed at the same time.

 

Software operating environment

Item Description

OS Microsoft(R) Windows(R) 10: 32bit / 64bit

PC

PC with the following software installed:
● Microsoft.NET Framework 4.6.1 or later
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
● Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
● Microsoft Visual C++ 2013 Redistributable Package (x86)
● Microsoft Visual C++ 2013 Redistributable Package (x64)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x86)
● Microsoft Visual C++ 2015 Update 3 Redistributable Package (x64)

HDD At least 4 GB of free space

Memory At least 8 GB

Communication port
LAN port (for Ethernet connection)
USB 2.0 port (for USB connection)

7.1 System Requirements
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7.2 Basic Operations

This section explains how to start and exit PANATERM Lite for GM.

7.2.1 How to Start

1. Click the [Start] button in the Windows task bar and select Panasonic
Corporation>PANATERM Lite for GM.

2. The "Connect" dialog box will be displayed.
Select communication settings and click [OK].

3. The "Series setting" dialog box will be displayed.

7.2 Basic Operations
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When the "Selection of Aircraft Types" dialog box is displayed, select a model and click the
"OK" button.

4. PANATERM Lite for GM will be started.

7.2 Basic Operations
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7.2.2 How to Exit

● Note that all information will be lost if you close the program without saving settings,
collected data, or other information.

1. From the menu bar, select File>Exit.
PANATERM Lite for GM will be closed.

● You can also close PANATERM Lite for GM by clicking the [×] button on the title bar.

7.2 Basic Operations
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7.3 Component Names

This section explains the components and displays of PANATERM Lite for GM.

No. Name Description

(1) Title bar The title bar displays the project file name, [minimize] button, [maximize] button, and
[close] button.

(2) Menu bar The menu bar displays the menu commands for each purpose in list format.

(3) Toolbar The toolbar displays each command as an icon.

(4) Navigator pane This pane displays a list of axes.

(5) Main pane
This pane displays the Parameter window, Monitor window, Alarm window, and other
windows.
The window can be switched by selecting a desired tab.

(6) Status field This field displays the status of connection to the GM1 controller.

7.3 Component Names
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7.4 Parameter Window

The Parameter window allows the user to check and rewrite the values of servo amplifier
parameters, save them to parameter files, and perform parameter-related operations.

7.4.1 Configuration of Parameters Window

No. Name Function

(1) Toolbar

The toolbar consists of basic operation commands related to parameters,
such as save and read.

Icon Name Function

Read

Reads parameters from file ".prm5".
When this button is enabled, you can
specify a parameter file also by drag-and-
drop operation.

Save Writes parameters to file ".prm5".

Rcv Receives parameters from the servo
amplifier.

7.4 Parameter Window
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No. Name Function

Icon Name Function

Trans Transmits parameters to the servo
amplifier.

Copy
Copies the parameters of a servo
amplifier to servo amplifiers for other
axes.

EEP Writes parameters to EEPROM of the
servo amplifier.

Bin / Hex Inputs the selected settings in binary or
hexadecimal format.

Print Prints parameters.

Pin assignment
setting Sets I/O pin assignment.

(2) Theme selection pane

After a theme is selected, if a parameter category is selected from a sub-
theme, related parameters will be displayed in the parameter setting area.

For details on each parameter, refer to the instruction manual and other
technical references for the servo amplifier.

(3) Parameter setting area

Allows the user to set or edit parameters.

Name Function

Class Displays parameter categories

No. Displays parameter numbers

Parameter Name Displays parameter names

Setup Range Displays the maximum and minimum allowable
values of parameter settings

Value

Displays parameter values. Values can be changed.
For parameters provided with a ▼ button beside the
set value, a desired value can be selected from the
combo box. After selecting a value from the combo
box, press the <Enter> key. For parameters without
a ▼ button beside the set value, either directly enter
a value using <numerical> keys or click "▲""▼" to
edit the value by increasing or decreasing it. To set a

7.4 Parameter Window
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No. Name Function

Name Function
value, press the <Enter> key. To return a value to its
original value, press the <Esc> key.

Unit Displays the unit of parameter settings.

(4) Text display area Displays a description related to the selected parameter.

(5) Parameter attribute
description area

Displays a description of parameter attributes. The background color of each
parameter in the parameter setting area represents an attribute.

(6) "Display-set value
description" check box

Selecting the check box displays combo boxes and decimal points in the
"Value" column of the parameter setting area. To display parameter set
values in an easy-to-understand manner, select the check box.

7.4.2 Setting Parameters

1. From the menu bar on the main pane, select Display>Parameter. Alternatively, on the
toolbar, click the"Open the Parameter view" icon.

The "Selection of parameter to be read" dialog box will be displayed.

7.4 Parameter Window
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Read-out from the driver
Communicates with the connected servo amplifier and reads the parameter settings from
the servo amplifier. If this mode is selected, parameter values will be reflected in the servo
amplifier as soon as they are changed.
Read from file
Read the parameter file (".prm5") that was edited previously. If communication is
performed with the servo amplifier, parameter values will be reflected in the servo amplifier
as soon as they are changed.
Read default
Reads the standard default settings of the servo amplifier that were saved during
installation. If communication is performed with the servo amplifier, parameter values will
be reflected in the servo amplifier as soon as they are changed.

2. Select one of the three options above and click the [OK] button.
The Parameter window will be displayed.

3. After changing the parameter settings, click the [EEP] button to write the parameter settings
to the EEPROM of the servo amplifier.

4. Click the [×] button on the Parameter window to close the Parameter window.

7.4 Parameter Window
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7.5 Monitor Window

The Monitor window displays the operating states of servo amplifiers and motors, I/O signals,
internal statuses, and other information and also allows the user to check them.

7.5.1 Configuration of Monitor Window

NO. Name Description

(1) Toolbar

The toolbar consists of basic operation commands related to parameters.

Icon Name Function

Print Prints the contents of the Monitor
window.

(2) Amplifier model name and
serial number Displays the model name and serial number of the servo amplifier.

(3) Output signal status
monitor

Displays the status of each output signal. The tab can be switched between
"Physical Output" and "Logical Output".
Physical Output – Displays the status of output signals from the servo
amplifier.
Red: Indicates that output transistor is ON
Pink: Indicates that output transistor is OFF

7.5 Monitor Window
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NO. Name Description
Logical Output – Displays the status of signals within the servo amplifier.
Red: Indicates that signal status is active
Pink: Indicates that signal status is inactive

(4) Input signal status monitor

Displays the status of input signals. The tab can be switched between
"Physical Input" and "Logical Input".
Physical Input – Displays the status of input signals to the servo amplifier.
Red: Indicates that COM- is connected
Pink: Indicates that signal status is open
Logical Input – Displays the status of signals within the servo amplifier.
Red: Indicates that signal status is active
Pink: Indicates that signal status is inactive

(5) Internal status monitor

Displays the internal status of the servo amplifier.

Name Function

Commanded
position deviation Displays the position deviation of a command unit.

Actual speed Displays the monitor speed

Torque command Displays the torque command.

Load factor Displays the ratio relative to the rated load. Adjust
the operation pattern so that 100% is not exceeded.

Power supply
voltage value

Displays the voltage (voltage between the P and N
terminals) of power supply to the servo amplifier.

(6) Pulse sum monitor Displays the sum of command and encoder pulses received by the servo
amplifier.

(7) Encoder information
monitor

Displays encoder information.

Single-turn data Displays an absolute position when the motor makes
no more than a single turn.

Multi-turn data Displays how many turns the motor made after
"Clear" operation.

Clicking "Clear Multi-turn" resets the multi-turn data stored in the encoder to
"0" and clears all encoder errors.
Note: Before using "Clear Multi-turn", check the precautions on use. To clear
encoder errors, you may need to restart the servo amplifier.

 

(Note 1) Because Ethernet communication is used to transfer data between the servo amplifier and PC, there
is a difference or delay between the value displayed on the screen and the actual value of the servo
amplifier.

(Note 2) When the polarity is "+", symbol "+" is not displayed.
(Note 3) The monitor function is not a measuring instrument. Use the values displayed in the Monitor window

as a guide.
(Note 4) If the servo amplifier outputs "Error 40.0　Error protection from absolute system failure" or "Error

42.0　Error protection from absolute overspeed", execute "Clear Multi-turn". Unless the absolute
encoder is reset, the alarm cannot be cleared.

 

7.5 Monitor Window
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7.5.2 Checking the Monitor Window

1. From the menu bar on the main pane, select Display>Monitor. Alternatively, on the
toolbar, click the"Open the Monitor view" icon.

The Monitor window will be displayed.

2. Check each item.
Check the input signal state, output signal state, and the internal status of the servo
amplifier.

3. Click the [×] button on the Monitor window.
The Monitor window will be closed.

7.5 Monitor Window
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7.6 Alarm Window

If the front panel of the servo amplifier is blinking, such as when the motor is not working, you
can check the alarm status.Please note that the alarm cannot be cleared.

7.6.1 Configuration of Alarm Window

Display of the current errors and warnings (only during communication with servo
amplifier)

7.6 Alarm Window
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Display of error histories

No. Name Description

(1) Toolbar

Icon Name Function

Clear

Allows the user to clear the current
alarm history. If you click this button
after eliminating the cause of the
alarm, the current alarm will be
cleared and normal operation will be
performed. However, you cannot
clear any alarms that cannot be
cleared by alarm clear input signals
of servo amplifiers. In such a case,
turn off the servo amplifier, eliminate
the cause of the alarm, and then
turn the power on again.

Clear Allows the user to clear error
histories.

Print Prints error-related information.

(2) Current error display area

Displays the alarm numbers and names of all errors that are currently
occurring.
The alarm displayed on the top of the list is the alarm displayed on the front
panel of the servo amplifier.

7.6 Alarm Window
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No. Name Description

(3) Error cause / treatment
display area Displays the cause and treatment of the selected error.

(4) Motor internal status
display area Displays the motor internal status in the event of an alarm.

(5) Current warning display
area

Displays the warning numbers and names of all warnings that are currently
occurring.

(6) Warning cause / treatment
display area Displays the cause and treatment of the selected warning.

(7) Error history display area Displays the order of error histories, alarm numbers, and error names.

(8) Error cause / treatment
display area

Displays the cause and treatment of the selected error.

(9) Motor internal status
display area

Displays the motor internal status in the event of an alarm.

 

(Note 1) Some alarms cause tripping as errors but are not recorded in error histories. For alarms that are not
recorded in error histories, refer to the instruction manual of the servo amplifier.

(Note 2) Up to 14 error histories are stored. When more than 14 errors occur, error histories are erased in
chronological order (the oldest error history is erased first).

(Note 3) Up to three histories of motor internal status in the event of an alarm are stored. If an alarm occurs
immediately after the power is turned on, motor internal status may not be captured normally.

 

7.6.2 Checking Alarms

1. From the menu bar on the main pane, select Display>Alarm. On the toolbar of the main
pane, click the"Open the Alarm view" icon.

The Alarm window will be displayed.

7.6 Alarm Window
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2. Check for any errors that are currently occurring.
Click the current "Now Error / Warning" tab and check for any errors that are currently
occurring.

3. Check for any errors that occurred in the past.
Click the "Error History" tab and check for any errors that occurred in the past.

4. Click the [×] button on the Alarm window.
The Alarm window will be closed.

7.6 Alarm Window
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7.7 Other Functions

7.7.1 Language Setting Function

This function allows the user to set the display language of PANATERM Lite for GM.
The default setting is the same language as the one set in GM Programmer.

1. Select a language from the menu bar tool.
The language set in PANATERM Lite for GM will be switched.

● The display language setting of PANATERM Lite for GM is linked with that of the GM
Programmer.

7.7.2 Help Function

While performing operation in PANATERM Lite for GM, you can start the Help function to check
information such as operating methods.

1. From the menu bar, select Help>PANATERM Lite for GM Help.
"PANATERM Lite for GM Operation Guide" will be started.

7.7.3 Version Display Function

This function allows the user to check the version, license, and other information for
PANATERM Lite for GM.

1. From the menu bar, select Help>Version Info.

7.7 Other Functions
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2. Click a desired button at the bottom of the window.

Button Description

Version Info Displays information about the plug-ins that have been applied and the operating
system of the PC that is used.

License Info Displays license information for the software used by PANATERM Lite for GM.

7.7 Other Functions
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8.1 Initial Setup for Servo Amplifiers

8.1.1 Connecting the Servo Amplifier and PC

Use a USB cable to connect the servo amplifier and a PC on which PANTERM Lite for GM has
been installed.

8.1.2 Installing the USB Driver

When the GM Programmer is installed, the USB driver is also installed at the same time.

8.1.3 Initial Setup for Servo Amplifiers

1. Start PANATERM Lite for GM.
The "Connect" dialog box will be displayed.

8.1 Initial Setup for Servo Amplifiers
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2. Select "AMP default setting" and click [OK].
The "Model confirmation" dialog box will be displayed.

3. Check the software version of the servo amplifier for which settings are to be changed and
then click [OK].
The "Parameter change" dialog box will be displayed.

8.1 Initial Setup for Servo Amplifiers
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If you use parameters "Absolute encoder setup", "Output pulse counts per one motor rev...",
"RTEX communication cycle setup", and "RTEX command updating cycle setup", change
the settings according to the operating environment.

4. Click [OK].
The "Setting Complete" dialog box will be displayed.

5. Click [OK].
The main pane will be displayed. Start the servo amplifier.

8.1.4 Disconnecting the Servo Amplifier from the PC

Disconnect the USB cable connecting the PC and the servo amplifier.

8.1 Initial Setup for Servo Amplifiers
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9.1 Setting an Address for Each Servo Amplifier

Set the MAC ID using the address switch of the servo amplifier.
The order of connections on the network is not related to the MAC ID.

● For details on how to set station numbers for servo amplifiers, refer to the instruction manual of
each servo amplifier.

9.1 Setting an Address for Each Servo Amplifier
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9.2 Connecting the GM1 Controller and Servo Amplifiers via RTEX

Connect the RTEX ports on the GM1controller and each servo amplifier.

9.2 Connecting the GM1 Controller and Servo Amplifiers via RTEX
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10.1 Connecting the GM1 Controller and PC

10.1.1 Selecting a Connection Port for GM Programmer

Select either LAN port connection or USB port connection.

10.1.2 Connecting the GM1 Controller and PC with a Cable

Use an Ethernet cable or USB cable to connect the GM1 Controller and a PC on which the GM
Programmer is installed.

10.1 Connecting the GM1 Controller and PC
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10.2 Creating a New Project

When creating a program using the GM Programmer for the first time, create a new project. For
the new project, set a device and a programming language to be used.
This section describes how to create a new project.
Given below is an example that explains the procedure to create a project for the GM1
controller (product number: AGM1CSRX16T) in Structured Text (ST) format.

1. Start up the GM Programmer.
For details on how to start up, refer to "6.3.1 How to start".
When the GM Programmer is successfully started, the Start Page will be displayed.

2. Select "New Project" under "Basic Operations".
The "New Project" dialog box will be displayed.

10.2 Creating a New Project
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3. Select Project>Standard project, and specify a project file name in the "Name" field and a
project storage location in the "Location" field.

4. Click the [OK] button.
The "Standard Project" dialog box will be displayed.

5. Select "AGM1CSRX16T(Panasonic Corporation)" in the "Device" field and "Structured Text
(ST)." in the "Program in" field, and click the [OK] button.

10.2 Creating a New Project
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A new project will be created. Device and other objects including objects for ST programs
are arranged in the navigator pane.

<Uses of objects arranged in the navigator pane>

No. Name Function

(1) Device object Sets up device objects.

(2) Application object Sets up application objects.

(3) Program object (POU object) Sets up program objects (POU objects).

(4) Task object Sets up task objects.

● A new project can also be created from the menu bar by selecting File>New Project.

10.2 Creating a New Project

WUME-GM1RTXSU-05 10-5



10.3 Communication Setting

10.3.1 Setting the LAN Port

Set communication settings of the LAN port through the network settings of the PLC
parameters.
When connecting the GM Programmer and the GM1 via the LAN port, match the PC network
settings with those of the GM1.

1. Double-click the "Device(AGM1CSRX16T)" object in the navigation pane.
The device editor will open.

2. Open the "PLC Parameters" tab.

3. Check the GM1 network settings and match the PC network settings with those of the GM1.

4. Open the "Communication Settings" tab and click "Network scan".

5. Select a GM1 Controller that you want to connect and click the [ OK ] button.

● When the GM1 settings have been changed, the changes will become valid after the
project is downloaded.

10.3.2 Addition of the USB Port

This function allows the user to set a USB port to the communication interface between the GM
Programmer , PANATERM Lite for GM, or other tool and the GM1 Controller.

1. Connect the GM1 Controller and PC with a USB cable .

2. From the menu bar, select Online>Add USB Port.

10.3 Communication Setting
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The "Add &USB Port" dialog box will be displayed.

3. Click the [OK] button.
A dialog box to restart the Gateway will be displayed.

4. Click the [OK] button.
The "Select Device" dialog box will be displayed.

10.3 Communication Setting
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5. Select a GM1 Controller that you want to connect and click the [OK] button.
When the connection is completed, a dialog box will be displayed to notify successful
connection.

6. Click the [OK] button.
A USB port is added the communication interface between the PC and GM1 Controller.

10.3 Communication Setting
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10.4 Adding and Setting up Servo Amplifiers

Add device objects for servo amplifiers to a project and set them up.
The description below explains how to add device objects for A6N servo amplifiers to a project
and how to set them up.

1. Right-click the [RTEX_Master] object in the navigator pane and then select "Device
Management" from the context-sensitive menu that is displayed.

The "Device Management" dialog box will be displayed.

2. Double-click the MAC ID row in the "Device: RTEX_Master" table.

● For the MAC ID, double-click the same No. as the No. set using the address switch of the
servo amplifier.

The "Select Device" dialog box will be displayed.

10.4 Adding and Setting up Servo Amplifiers
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3. Select a device object for the servo amplifier.
The selected device object of the servo amplifier will be added.

4. Click the [Select Device] button.

10.4 Adding and Setting up Servo Amplifiers
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● Match the "bite mode" to the byte mode setting of the servo amplifier.
● A servo amplifier set to 16 bytes in "byte mode" is counted as 1 block, and a servo

amplifier set to 32 bytes is counted as 2 blocks. You can add devices up to a total of 32
blocks.

5. Click the [OK] button.
The selected device object of the servo amplifier will be added to the navigator pane.

6. Double-click the added object.
The setting pane will be displayed in the main pane. Specify settings related to servo
amplifier A6N.

10.4 Adding and Setting up Servo Amplifiers
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● To remove a device object that has been added, select the device object in the navigator pane
and press the "Delete" key.

10.4 Adding and Setting up Servo Amplifiers
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10.5 Basic Settings of the RTEX Axis

● Be sure to set the RTEX axis,

1. Double-click the servo amplifier object in the navigator pane.

2. From the displayed menu, select "Edit Object".
The "RTEX Axis Setting" dialog box will be displayed.

10.5.1 General Settings

Select the "General" tab and set the following items.

(1) Virtual mode
You can set the real axis or virtual axis.
Use of the real axis: The real axis is used to actually control the servo amplifier.
Use of the virtual axis: A virtual servo amplifier is created in the GM1 Controller and its virtual
axis is used.

10.5 Basic Settings of the RTEX Axis
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(2) Modulo / Finite
The axis type can be specified.
● Modulo

Modulo: The motor rotates infinitely (belt drive, etc.) without limiting the travel range.
• The command position value keeps looping between 0 and modulo value.
• The maximum settable modulo value is "255×units in application"(*1).

*1: Set the units in application in the Scaling / Mapping.
• A negative value cannot be set. (A warning is issued. If the data is downloaded as is, an

error will occur when executing the GM1.

● Finite
The set value for the command position is a finite value.
Software limit can be set. Note that an error will occur if a 32-bit real number is exceeded.

(3) Software limit
A software limit can be set if the axis type is set to “Finite”.
If the command position is outside the software limit setting range, an error stop occurs and
operation stops.
When operation is stopped by exceeding the software limit, the shortest time from the start of
deceleration to the stop among the following settings is applied: the value set for the
deceleration in response to the software error, for the maximum distance in response to the
software error, or for the dynamic limit.

(4) Software error reaction
Settings can be made to stop operation when an error occurs.

10.5 Basic Settings of the RTEX Axis
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● When operation is switched from Run to Stop, an emergency stop is made regardless of the
software error reaction.

● For the stop operation that takes place when an error stop occurs or when the software limit is
exceeded, the shortest time from the start of deceleration to the stop among the following
settings is applied.
• Deceleration in software error reaction
• Maximum distance in software error reaction
• Dynamic limit

● If the deceleration and maximum distance in software error reaction are set to 0, these become
invalid. In that case, operation stops according to the deceleration rate set in the dynamic limit.

(5) Dynamic limit
Speed, acceleration, and deceleration settings cannot be set to 0. If they are set to 0, a
warning is issued.

The values set in the dynamic limit can be checked if they are exceeded during axis
operations using the "SMC_CheckLimits" function block Note that an excess of the jerk cannot
be detected using the "SMC_CheckLimits" function block. Therefore, do not use the jerk
column.

10.5.2 Scaling / Mapping Settings

Select the "Scaling/Mapping" tab and set the following items.

(6) Scaling/Mapping
● Rotary type

When the axis type is set to modulo, the ratio in the conversion from the drive increment to
the application unit is set.
The unit on the servo amplifier and the unit on the application (POU) are converted.
Example:
One rotation of the MINAS A6N is 0x800000. To treat one rotation as 360 on the
application, set this to 360.

10.5 Basic Settings of the RTEX Axis
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Note: Invert direction: The direction is inverted.
● Linear type

When the axis type is set to finite, the ratio in the conversion from the drive increment to the
application unit is set.

Note: Invert direction: The direction is inverted.

10.5 Basic Settings of the RTEX Axis
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10.6 Connecting to the GM1 Controller

Connect the PC where the GM Programmer is installed to the GM1 Controller.
The connection status of the PC includes "Connected", "Connection as a device user", "Login",
and "Online config mode".
Depending on the connection status, operations that can be executed are different.
If the Controller is provided with a device user registration, connection must be made as the
device user.

■ Without device user registration

List of available GM1 Controller operations

Function Not connected Connected Login Online config mode

Setting / acquiring Controller
information

× ○ ○(Note 1) ×

Application management × ×(Note 2) ○ ×

Reset × ×(Note 3) ○ ×(Note 4)

Security × × ○ ○

Debug × × ○ ×

Commissioning × × × ○
 

(Note 1) Not possible to operate the PLC Shell.
(Note 2) Possible to upload the source.
(Note 3) Possible to reset the device (PLC initialization) or to delete device application from the device.
(Note 4) Possible to reset the device (PLC initialization).
 

10.6 Connecting to the GM1 Controller
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■ With device user registration

List of available GM1 Controller operations

Function Not
connected

Connected \as a device user Login Online config
mode

Setting / acquiring
Controller information

× × ○ ○(Note 1) ×

Application management × × ×(Note 2) ○ ×

Reset × × ×(Note 3) ○ ×(Note 4)

Security × × ○(Note 5) ○ ○

Debug × × × ○ ×

Commissioning × × × × ○
 

(Note 1) Not possible to operate the PLC Shell.
(Note 2) Possible to upload the source.
(Note 3) Possible to reset the device (PLC initialization) or to delete device application from the device.
(Note 4) Possible to reset the device (PLC initialization).
(Note 5) Addition of the device user, changing the password for the device user, or deletion of the device user

cannot be made if the user of the Device Editor is not synchronized with "Synchronization" of the
group tab.

 

10.6 Connecting to the GM1 Controller
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10.7 Commissioning

10.7.1 Online Config Mode

When the online config mode is selected, the servo amplifiers are set to be connected to the
GM1 Controller.

When using the online config mode, perform the setting as described in "10.3 Communication
Setting" in advance.

1. From the menu bar, select Project>Online Config Mode.
A confirmation message will be displayed, asking whether to remove all applications.

2. Click [Yes].
All applications will be removed from the GM1 controller, and the GM1 controller and servo
amplifiers will be connected in online config mode.
While online config mode is in progress, "Online Config Mode" in the menu bar remains
selected.

● To cancel the online config mode, select Project>Online Config Mode from the menu bar
again.

10.7 Commissioning
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10.7.2 Conducting Commissioning for Servo Amplifiers

While in the online config mode, you can conduct commissioning for servo amplifiers.
There is no need to create a program for commissioning.
The following is an example of commissioning using the A6N-series servo amplifiers.

1. Double-click the servo amplifier object in the navigator pane.

The "RTEX Axis Setting" dialog box will be displayed.

2. Click the "Commissioning" tab.
The Commissioning screen will be displayed.

10.7 Commissioning
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Group Description

Drive
Allows the user to set commissioning parameters.
Allows the user to execute commissioning.

Status Displays the running status of the servo amplifiers during commissioning.

Error
Displays errors that occurred during commissioning.
Allows the user to clear errors.

3. Click an appropriate button in the Operation group to start commissioning.
Clicking an icon starts the corresponding commissioning procedure.
To change home return parameters, use the "Home Return Settings" tab.

10.7 Commissioning
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4. For the servo amplifier and RTEX statuses during commissioning, check the "Status" and
"Error" groups.

4-1 To erase errors that are displayed, click the [Clear] button or [All Clear ] button in the
"Error" group.
● Pressing the [Clear] button will erase axis errors, drive errors, RTEX errors, and

FB errors [0].
● Pressing the [All Clear] button will erase axis errors, drive errors, RTEX errors,

and FB errors [0] to [5].

If the display of FB errors is collapsed, the number of FB errors will be displayed as
"0" in the "Error Content" column.

5. From the menu bar, select Project>Online Config Mode.
If online config mode is canceled, commissioning will be terminated.

This completes commissioning for servo amplifiers.

10.7 Commissioning
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● If you display another window during commissioning, "Stop" will be executed.
● Even if communication with the servo amplifier is disrupted during "Inching" or "Home Return"

operation, the servo amplifier will continue commissioning operation.
● If online config mode is canceled, commissioning will be terminated. To cancel the online config

mode, select Project>Online Config Mode from the menu bar again.

10.7 Commissioning

WUME-GM1RTXSU-05 10-23



10.8 Login

GM Programmer allows the user to log in to the GM1 Controller. When "Login" is executed,
applications are downloaded to the GM1 Controller.

1. From the menu bar, select Online>Login, or press the <Alt> key and the <F8> key
simultaneously.
A confirmation message will be displayed, asking whether to download the applications to
the GM1 controller (device).

2. Click [Yes].
The applications will be downloaded to the GM Programmer at the same time as you log in
to the GM1 Controller (device).
"connected" will be displayed at the [Device] object in the navigator pane and the status of
the downloaded applications will be displayed.

● You can also log in by clicking  on the toolbar.
● If you log in again after the applications have been downloaded, the confirmation message will

not be displayed.

10.8 Login

10-24 WUME-GM1RTXSU-05



10.9 Logout

This function allows the user to log out from the device to which the user logged in.

1. From the menu bar, select Online>Logout, or press the <Ctrl > + <F8> key simultaneously.
You will be logged out.

● You can also log out by clicking  on the toolbar.

10.9 Logout
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11.1 Setting up the Servo Amplifier Connected to the GM1 Controller

The PC communicates with the servo amplifier connected to the GM1 Controller.
Connect the PC and GM1 Controller with a USB cable or Ethernet cable. With the GM1
Controller and servo amplifier connected with a Cat5e shielded cable, set up the servo
amplifier.

Make this setting only after the connection between the GM1 Controller and the servo
amplifier has been established.

11.1.1 When Connected Using the Ethernet Cable

If connected using the Ethernet cable, use the following procedure.

1. Start PANATERM Lite for GM.
The "Connect" dialog box will be displayed.

2. Select "Connect to the GM series controller with LAN" and click the [OK] button.
The "Communication timeout settings" dialog box will be displayed

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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3. Change the timeout time and click the [OK] button.
The "Select Device" dialog box will be displayed.

4. Click the [Scan Network] button, select the GM1 Controller, and click the [OK] button.
The main pane will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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11.1.2 When Connected Using the USB Cable

If connected using the USB cable, use the following procedure.

1. Start PANATERM Lite for GM.
The "Connect" dialog box will be displayed.

2. Select "Connect to the GM series controller with USB" and click the [OK] button.
The "Add USB Port" dialog box will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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3. Change the timeout time and click the [OK] button.
A dialog box to add a USB port and to restart the Gateway will be displayed.

4. Click the [OK] button.
The "Select Device" dialog box will be displayed.

5. Click the [Scan Network] button, select the GM1 Controller, and click the [OK] button.
The main pane will be displayed.

11.1 Setting up the Servo Amplifier Connected to the GM1 Controller
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11.2 Writing Parameters to Servo Amplifier

Connect the PC with the servo amplifier and directly write the parameters set with PANATERM
Lite for GM to the servo amplifier.

1. Start PANATERM Lite for GM.

2. Click "Trans" on the toolbar.
The parameters will be sent from PANATERM Lite for GM to the servo amplifier.

● When changes were made to the parameters with yellow background, click “EEP” on the
toolbar to restart the servo amplifier.

11.2 Writing Parameters to Servo Amplifier
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12.1 Checking Wiring

Firstly, check whether the GM1 Controller, expansion units, servo amplifier, and PC are
connected correctly.

12.1 Checking Wiring
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12.2 Checking Safety Circuit Design

12.2.1 Safety Circuit Design

■ Example of a safety circuit
Be sure to create a safety circuit when using this product.

Installation of over limit switches

● Install over limit switches as shown above.
● Connect them to the CW and CCW over-travel inhibit inputs of the parallel I/O connector of

the servo amplifier. For the GM1 Controller, connect them to the limit input (+) and limit input
(-) through the network.

● Install the safety circuit recommended by the manufacturer of the motor being used.

12.2 Checking Safety Circuit Design

WUME-GM1RTXSU-05 12-3



12.2.2 Items to Check during Wiring

■ System configuration example

(1) Checking connections of each device
Check to make sure that each device has been connected as indicated by the design.

(2) Checking the installation of the external safety circuit
Check to make sure the safety circuit (wiring and installation of over limit switch) based on the
external circuit has been installed properly.

(3) Checking the settings for power ON sequence
Make sure that settings have been entered so that power supplies will be turned according.

(4) Checking the GM1 Controller mode selector switch
Set the GM1 Controller to the STOP mode. Setting it in the RUN mode can cause inadvertent
operation.

 REFERENCE 
12.2.3 Power ON Operation

12.2.3 Power ON Operation

When turning ON the power supply to the system incorporating the GM1 Controller, turn ON the
power supply in the following order.

12.2 Checking Safety Circuit Design
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● Consider the nature and statuses of any external devices connected to the system, and
take sufficient care so that turning ON the power supply will not initiate unexpected
movements.

1. Turn ON the power supplies to the I/O devices connected to the GM1 Controller.

2. Turn ON the power supply to the servo amplifier.

3. Turn ON the power supply to the GM1 Controller.

12.2.4 Power OFF Operation

1. Check to make sure the rotation of the motor has stopped, and then turn OFF the power
supply to the GM1 Controller.

2. Turn OFF the power supply to the servo amplifier.

3. Turn OFF the power supplies to the I/O devices connected to the GM1 Controller.

12.2 Checking Safety Circuit Design
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12.2 Checking Safety Circuit Design
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12.3 Operation Check

12.3.1 Checking the Network

After turning ON the power supplies, check if the operation monitor LEDs of the GM1 Controller
are in the following states.
● STATUS: Lit
● LINK: Lit

● If the "STATUS" LED is flashing, the network is not established.
● If the "LINK" LED is not lit, the “RX” (reception side) of the GM1 Controller and “TX”

(transmission side) of the servo amplifier are not electrically connected normally.

12.3.2 Checking Input Signals

Check the input of the over limit switch for the safety circuit connected to the servo amplifier
and the input of the near home (DOG) switch.
Check whether signal inputs are properly loaded into the GM1 Controller, with each switch
operated forcibly.
The input state of each switch can be checked on the monitor screen of the MINAS Series
Setup Support Software "PANATERM Lite for GM".

● If the operating direction of the motor is opposite to the position of the limits (+) and (-) after the
installation of the over limit switch, check the physical connection of the limit switch.

12.3 Operation Check
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12.3.3 Checking Rotating and Moving Directions and Moving Distance

Check whether the rotating and moving directions of the motor and the moving distance are
correct. The operations can be easily confirmed using the commissioning function of the GM
Programmer without user programs.

■ Using the commissioning function
On the GM Programmer, select Project>Online Setting Mode.
Open the “Commissioning” screen for each axis to use the commissioning function.

■ Checking the rotation direction
Set the rotation direction on the servo amplifier.
Check the rotation direction by executing inching operation on the Commissioning screen.

■ Checking the moving distance
Set the moving distance on the servo amplifier.

12.3 Operation Check
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Next, set the scale on the "Scaling / Mapping" screen for each axis on the GM Programmer.
Check the moving distance by executing inching operation on the Commissioning screen.

For details on inching operation on the Commissioning screen, refer to "10.7.2 Conducting
Commissioning for Servo Amplifiers".

12.3 Operation Check
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Warranty

Warranty Period

The warranty period of the Product shall be 12 months from the ex-factory date or 18 months
from the date of manufacturing unless otherwise specified between both parties.

Warranty Scope

Panasonic warrants the replacement of the defected parts of the Product or repair of them
when the defects of the Product occur during the Warranty Period, and when the defects are
under Panasonic responsibility. This Warranty only covers the Product itself and does not cover
any damage to your company and the third party incurred by the Product, such as damage that
is induced by an object machined or produced using the Product or by the defects of the
Product. This Warranty shall be exempted in the following cases,
1. Defects resulting from misuse and/or repair or modification by the customer.
2. Defects resulting from drop of the Product or damage during transportation.
3. Defects resulting from improper usage of the Product beyond the Specifications.
4. Defects resulting from fire, earthquake, lightening, flood, damage from salt, abnormal

voltage or other Act of God, or other disaster.
5. Defects resulting from the intrusion of foreign material to the Product, such as water, oil or

metallic particles.
6. Parts exceeding their standard lifetime specified in this document.
7. The machines are not assembled in accordance with the instructions or precautions noted

in this specification.
8. When the machine does not match the Product assembled in the machine.
9. When the machine condition is not caused by Panasonic reasons.
10. Defects that Panasonic could not foresee at the time of delivery of the Prodcuct.

Warranty
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Cautions for Proper Use

■ Selection of a power supply
● Use a low noise power supply.
● The inherent noise resistance is sufficient for the noise superimposed on the power wires,

however, the noise can be attenuated further by using the isolation transformer / insulated
power supply.

■ Isolation of power supply systems
● Wiring to the units, I/O devices, and other power devices should have separate wiring

systems.

■ Power supply sequence
● Start the GM1 controller only after I/O devices and power devices are energized.

In case of stopping the operation of the GM1 controller, have the I/O devices or power
devices turned OFF after the GM1 controller has stopped operating.

■ Grounding
● The grounding connection should have a resistance of 100 Ω or less.
● The point of grounding should be as close to the GM1 controller as possible. The ground

wire should be as short as possible.
● Sharing the ground with another device may have an adverse effect. Therefore, be sure that

grounding is dedicated.

Conversely, depending on your environment, grounding may cause a problem. Do not ground
the function earth when grounding a plus (+) terminal of the power.

Cautions for Proper Use
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■ Wiring
● Turn OFF the power supply when carry out wiring or connecting the GM1 controller to

expansion units.
● Noise resistance measures such as attaching a noise filter, a surge absorber or a ferrite core

may be necessary in some cases, depending on the usage environment.

■ Installation of an interlock circuit
● When controlling conflicting operations such as the motor rotation in clockwise or counter-

clockwise direction, provide an interlock circuit external to the GM1 controller.

■ Installation of an emergency stop circuit
● Provide an emergency stop circuit external to the GM1 controller to turn OFF the power

supply of the output device.

■ Installation environment
Do not use it in the following environments.
● Direct sunlight
● Sudden temperature changes causing condensation.
● Inflammable or corrosive gas.
● Excessive airborne dust, metal particles or saline matter.
● Benzine, paint thinner, alcohol or other organic solvents or strong alkaline solutions such as

ammonia or caustic soda.
● Direct vibration, shock or direct drop of water.
● Influence from power transmission lines, high voltage equipment, power cables, power

equipment, radio transmitters, or any other equipment that would generate high switching
surges. (100 mm or more)

■ Handling instructions
● Before touching the unit, always touch a grounded piece of metal in order to discharge static

electricity.
● Always rid yourself of any static electricity before handling this product.
● Do not connect a unit other than our GM1 series to the side connector on the unit.
● Use copper wires with a temperature rating of 90°C or higher.

Cautions for Proper Use
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Revision History

The manual code is shown at the bottom of the cover page.

Date of issue Manual code Revision details
February 2021 WUME-GM1RTXSU-01 First Edition

August 2021 WUME-GM1RTXSU-02 2nd Edition
● Added the following models.

• Digital I/O unit (Source type)
• Analog I/O unit
• Pulse output unit

March 2022 WUME-GM1RTXSU-03 3rd Edition
● Clerical corrections

April 2022 WUME-GM1RTXSU-04 4th Edition
● Changed the Company name

November 2023 WUME-GM1RTXSU-05 5th Edition
● Made changes associated with RTEX

maximum 32 axes
● Windows® 11: 64-bit support
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